Sunday, 31 July 2011

Atlassian JIRA Startup Failed: Configuring JIRA to access SQL Server 2008 Express R2

I recently upgraded my SQL Server 2008 Express Edition with Advanced Services to R2, and found that my JIRA installation stopped working (received Tomcat 404 errors).

I tried everything, but could not get it to work - I kept getting 'connection refused' errors in the JIRA logs. I hadn't modified my server.xml configuration since the upgrade, and I checked that the protocols in SQL Server Configuration Manager were enabled on Port 1433.

Something wasn't right - even with the same configuration as before I just could not get JIRA to start.

Eventually, I found the answer which worked for me:

  • Run config.bat in the /bin folder of the JIRA installation folder.
  • Click the Database Tab:
  • Database type: SQL Server
  • Hostname: localhost (Or your server name. Note: NOT "localhost\SQLExpress")
  • Port: 49374 (Find this value in your registry, in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\SQLEXPRESS\MSSQLServer\SuperSocketNetLib\Tcp for your SQL instance name. i.e. SQLEXPRESS. You can edit your registry by typing 'regedit' at the command line.)
  • Database: jiradb
  • Username: jirauser
  • Password: *****
  • Schema: jiraschema
  • Connection Pool: 20
  • Click Test Connection.
Hopefully the utility will return 'Connection successful.'. Restart the Atlassian JIRA service and you should find that you are able to access your JIRA installation.

Worked for me - I'm not sure why I needed to do this for R2.

More info in the comments attached to this forum post.